Excel: como fazer o PROCV realizar pesquisas inversas

Fábio Vianna, especial para a PC WORLD*
06/05/2009 - 16h01 - Atualizada em 22/08/2009 - 11h23
Recurso que busca por dados varre somente à direita da coluna de pesquisa. Aprimore a função e localize o que quiser.

dicas_excel_150A função PROCV, no Excel, serve para localizar um valor na primeira coluna de uma matriz de tabela e retornar um valor na mesma linha de outra coluna na matriz da tabela.

Sempre que usamos essa função, sabemos que ela procura informações somente à direita da coluna de pesquisa (veja imagem).

Na célula F8, colocamos a função PROCV para procurar, na tabela da esquerda, as vendas do produto selecionado (no exemplo, produto d).

Note que a sintaxe do PROCV não inclui a coluna de códigos, uma vez que, como a pesquisa se dará pela descrição, esta coluna deverá ser sempre a 1ª do intervalo de dados – daí o porquê da função considerar a área de B7 até C13. Veja:

excel_1.jpg

Muito bem. E se quisermos saber o código que pertence àquele produto? O PROCV não servirá, pois ele busca somente à direita, e nesse caso precisamos buscar à esquerda.

Para esse caso usaremos duas outras funções de procura e referência do Excel: índice e CORRESP.

Essas duas funções são bastante úteis. Se alguém quisesse conhecer apenas 20 funções importantes do Excel, deveria considerá-las nesta lista.

A função CORRESP (match, em inglês)
Esta é uma função simples que retorna a posição de um item dentro de uma lista.
Imagine a nossa lista de produtos que vai do Produto A até o Produto F. A posição do Produto A nesta lista é 1, a do Produto D é 4, e assim por diante. É exatamente isto o que o CORRESP faz: a partir de um item e uma lista, ele diz em que posição este item está.

A sintaxe do CORRESP é:
=CORRESP(ITEM;LISTA;TIPO DE PESQUISA)

onde:

ITEM: é o que a função irá procurar na lista. Se fôssemos utilizar o exemplo acima, o item seria a célula E8.

LISTA: é o intervalo onde os itens aparecem. No nosso caso, são os produtos (área de B8 até B13).

TIPO DE PESQUISA: representa a forma pela qual queremos que o CORRESP pesquise na lista e pode ter os seguintes valores:

0 (zero): ele buscará exatamente o item na lista, e se ele não existir, a função retornará erro.

1 (um): ele pesquisará o item mais próximo do que procuramos na lista, que precisará estar em ordem alfabética crescente.

-1 (menos um): ele pesquisará o item mais próximo do que procuramos na lista, que precisará estar em ordem alfabética decrescente.

Como preciso encontrar o nome exato, vamos usar o zero.

Nossa função ficaria assim:

excel_2.jpg

E a resposta seria 4 (o produto d é o 4ª da lista que começa no Produto A).

Mas isso não serve para trazer o código. É aí onde entra a função ÍNDICE.

A função ÍNDICE (index, em inglês)
A função ÍNDICE faz o inverso do CORRESP.  Enquanto que o CORRESP diz em que posição algum item está, o ÍNDICE busca determinado item da tabela.

Por exemplo, se eu quisesse trazer o Produto B, eu “diria” para o ÍNDICE trazer o 2º item da lista que começa no produto A.

Sua sintaxe é:
=ÍNDICE(LISTA; NÚMERO DA LINHA;NÚMERO DA COLUNA)

No nosso exemplo, não precisamos determinar a coluna, pois teremos apenas uma coluna para pesquisa – o código.

Como o CORRESP disse que o produto D estava na 4ª posição da lista, agora vamos fazer o índice pegar o 4º item da lista de códigos.

Nossa função ficaria:

excel_3.jpg

E a resposta seria 1.4 (o código do produto D, que está na 4ª posição da lista).
Para economizarmos espaço, vamos juntar essas duas funções em uma célula apenas (o chamado aninhamento).

Colocamos a função na célula G8, e ela ficaria assim:
=ÍNDICE(A8:A13;CORRESP(E8;B8:B13;0))

Agora, sempre que alterarmos o nome do produto, ele trará o código, como se fosse um PROCV “inverso”.

Assine a Newsletter. É rápido. É grátis.

White Papers

Transforme dados em informações estratégicas para o seu negócio

As organizações de hoje em dia buscam uma abordagem à análise de autoatendimento que equilibre as necessidades da equipe de TI e da empresa. Com quatro importantes etapas a TI pode deixar de ser uma “fábrica de relatórios” para assumir um papel mais estratégico de governança e disponibilização de dados e ainda é possível implantar com sucesso a análise de autoatendimento. Acesse agora o ebook e confira as 4 etapas para uma implementação bem sucedida da análise de autoatendimento em sua empresa.

Quero migrar para a nuvem, mas como devo começar?

Desenvolvido pelos especialistas em TIC da Algar, este guia irá esclarecer todas as suas dúvidas sobre o processo de migração para a nuvem e mostrará como é possível reduzir custos de infraestrutura e manutenção. Descubra por que as empresas estão aderindo ao Cloud. Acesse o guia agora e veja 8 passos importantes para realizar a migração de aplicações e serviços de sua empresa para a nuvem.

8 dicas para reduzir os custos de TI da sua empresa

Os especialistas em TIC da Algar Telecom desenvolveram um E-book exclusivo para os gestores de TI. As dicas que serão apresentadas a seguir têm o propósito de ajudar os gestores no caminho de revisão estrutural do negócio, tendo como meta a redução de custos, mas com a manutenção da qualidade e eficiência. Acesse agora o e-book e veja como aumentar a performance de seu TI economizando.

Reviews

Mais reviews

Belo design, capas coloridas permitem personalizar o aparelho
Tela grande e de ótima qualidade
Bom desempenho e autonomia de bateria
Tem slot para cartões microSD

Câmera traseira tem foco fixo
Não tem flash
Não tem câmera frontal
Só 4 GB de memória interna

Desempenho excepcional
Excelente autonomia de bateria

Tela tem péssima qualidade de imagem
Grande e desengonçado