Home > Dicas

Excel: O que acontece se…

Como fazer cálculos condicionais com o Excel e chegar com facilidade às informações de que você precisa para tomar decisões.

PC World/Espanha

12/07/2005 às 16h59

Foto:

Embora o Excel traga uma bateria de mais de trezentas funções, poucas vezes as usamos. A função condicional 'SE', por exemplo, permite resolver situações muito corriqueiras no dia-a-dia de pessoas comuns e de empresas. E essa função é ainda mais poderosa quando combinada com outras, como veremos a seguir.

1) Prêmio por vendas
Suponhamos que você queira premiar com 500 reais os vendedores que conseguiram superar a meta de vendas de 10.500 reais. Considerando os montantes das vendas na coluna C, a partir da segunda linha (reservamos a primeira para títulos), o prêmio é obtido escrevendo na D2 a função condicional =SE(C2>10500;500;0).

A função condicional SE tem três argumentos entre os parêntesis. O primeiro é a condição da qual depende o valor que finalmente devolverá a fórmula. No caso do exemplo, que as vendas superem a meta de 10.500 reais. O segundo é o valor que devolverá a fórmula se a condição é satisfeita. No caso, o prêmio de 500 reais. O terceiro é o valor que devolverá a fórmula se a condição não for satisfeita. No caso, o valor é zero, porque para eles não há prêmio. A função escrita na D2 deve estender-se assim para toda a lista.

2) Soma com condições
A função SE não é a única função condicional do Excel. Por exemplo, a planilha 1 indica, na coluna B, a região a que pertence cada vendedor. Queremos calcular o total de vendas da região Sul. Para isto, podemos usar a função SOMASE. Digite =SOMASE(B2:B11;"Sul";C2:C11), tal como se vê na planilha 2. Esta função também tem três argumentos entre os parêntesis.

O primeiro é a faixa onde se avalia a condição. Neste caso, onde se indica as regiões. O segundo é o valor que deve ter a faixa anterior para que seja levado em conta na soma. Neste caso, a palavra Sul. O terceiro é a faixa que se soma. Neste caso, a das vendas.

A função SOMASE compara a célula da faixa indicada como primeiro argumento com o valor do segundo. Quando se satisfaz a igualdade, soma o valor correspondente do terceiro argumento.

3) Condicionais combinadas
O cálculo anterior pode ser feito também com uma variante pouco conhecida da função condicional, combinando-a com a somatória: =SOMA(SE(B2:B11= “Sul”;C2:C11)). Porém, atenção. Depois de digitar essa função, em vez de simplesmente pressionar a tecla Enter, pressione as teclas Control, Shift e Enter simultaneamente.

Como se vê na Planilha 3, a fórmula fica entre chaves. Estas chaves não são escritas, apenas aparecem como conseqüência de ter sido usada a combinação Control + Shift + Enter. Nesta expressão se avalia a condição de ter o valor Sul na faixa B2:B11. Se a condição é satisfeita, soma-se o valor de C2:C11. O resultado é o mesmo que o encontrado pela função SOMASE.

4) Mais de uma condição
A fórmula do exemplo anterior admite variantes mais complexas. Por exemplo, na planilha 4 combinamos a soma e a condicional para somar as vendas da região Sudeste que superam os 10.000 reais: =SOMA(SE(B2:B11= "Sudeste";SE (C2:C11>10000;C2:C11))).

Como nos casos anteriores, pare inserir esta função é preciso pressionar as teclas Control + Shift + Enter. Esta fórmula avalia primeiro a condição de pertencer à região Sudeste do País. Se esta condição é satisfeita, avalia se as vendas realizadas são maiores que 10.000 reais. Se esta segunda condição é atendida, soma-se o correspondente valor de vendas.

5) Contagem condicional
Em princípio, qualquer função estatística ou matemática pode ser sujeita a uma condição. Por exemplo, a planilha 5 mostra uma lista de alunos com a qualificação obtida na coluna C. Quantos alunos do turno da tarde obtiveram uma nota maior que 5? Neste caso, temos de vincular as funções SE e CONTAR: =CONT.NUM (SE(B2:B11="Tarde";SE(C2:C11>5;C2:C11))).

Como nos outros casos, deve-se inserir esta expressão com a combinação Control + Shift + Enter. A expressão avalia as condições de pertencer ao turno da Tarde e ter uma nota maior que 5. Se ambas as condições forem alcançadas, conta-se as notas.

6) Máximo condicional
Agora, vamos supor o caso de uma planilha de duas colunas: na primeira, temos datas e, na segunda, temos os nomes dos clientes que visitamos em cada data. O mesmo nome pode se repetir na lista porque o visitamos mais de uma vez. Queremos saber quando foi a última vez que estivemos com Pedro.

Este problema equivale a encontrar a maior data (isto é, a última) para a qual, na segunda coluna, está o valor Pedro: =MAXIMO(SE(B2:B11="Pedro";A2:A11)). Esta fórmula se interpreta de forma similar às anteriores: avalia-se se na faixa B2:B11 está o valor Pedro. Das fileiras que satisfazem esta condição, busca a que tem o máximo valor na coluna de datas.

Tags

Junte-se a nós e receba nossas melhores histórias de tecnologia. Newsletter por e-mail Newsletter por e-mail