Home > Dicas

Numeração automática de lista

Veja como numerar itens em células não consecutivas em planilhas do Excel e do 1-2-3.

PC World

18/07/2005 às 16h43

Foto:

No Excel, para numerar itens em células não consecutivas, basta interligar as fórmulas que se referem às células da coluna B nas células da coluna A. A fórmula a seguir exibe o próximo número de item consecutivo se uma célula tiver algo nela; se a célula estiver vazia, não exibe nada:

=SE(B1<>"";CONT.VALORES($B$1:B1)&".";"") ou =IF(B1<>"",COUNTA($B$1:B1)&".",""), na versão em inglês do Excel

Depois de digitar a fórmula, você pode copiá-la coluna abaixo quantas vezes for preciso para lidar com todos os itens que você estiver digitando. No 1-2-3, use a seguinte fórmula para produzir o mesmo resultado:

@IF(B1="","",@STRING(@COUNT($B$1..B1),0)&".")

Tags

Junte-se a nós e receba nossas melhores histórias de tecnologia. Newsletter por e-mail Newsletter por e-mail