Home > Dicas

5. Função Índice com duas variáveis

15/12/2005 às 15h05

Foto:

Agora, para fazer o valor da célula B4 variar também conforme o botão de opção, será necessário modificar a fórmula da função Índice, acrescentando um segundo critério. A sintaxe deve ser a seguinte: “=INDICE(B11:D14;A16;A17)”, sem as aspas. Neste caso, o primeiro argumento (B11:D14) é a tabela com a matriz de preços, o segundo (A16) indica a linha desta tabela e o terceiro (A17) aponta a coluna.

Excel interativo 5 - 400x

Pronto! A planilha está concluída. Podemos indicar a duração da estadia pela barra de rolagem, escolher o hotel pela caixa de combinação e selecionar o tipo de quarto pelos botões de opção. Estes mesmos objetos podem ser utilizados para padronizar e automatizar o trabalho com qualquer planilha que envolva células cujos valores variam com freqüência, como a duração da estadia, ou sejam provenientes de uma lista, como preços dos quartos.

Passos anteriores

Introdução

1. Barras de rolagem

2. Caixas de listagem

3. A função Índice
4. Botões de opção

Tags

Junte-se a nós e receba nossas melhores histórias de tecnologia. Newsletter por e-mail Newsletter por e-mail