Home > Notícias

Usuários de Mac enfrentam problemas com programas do IRPF 2010

Informações confusas e incompatibilidade com sistemas operacionais anteriores estão entre as dificuldades

Daniel dos Santos, Macworld Brasil

02/03/2010 às 11h19

Foto:

Quem usa Mac não costuma encontrar vida fácil quando o assunto é declaração do imposto de renda. No ano passado, uma informação incorreta fazia com que quem tentasse instalar o Receitanet  perdesse um bom tempo com códigos de linha de comando no Terminal do Mac OS X (ela fazia referencia à versão de 2008 no código, não à versão 2009).

Agora, quem usa Mac enfrenta outros problemas. Para começar, quem baixa o Receitanet em sua versão 2010 para Mac encara novamente as linhas de comando do Terminal, processo complicado para usuários comuns. Nesse caso, a melhor maneira é não usar o Receitanet para Mac.  Prefira o download do Receitanet multiplataforma, que é muito mais fácil de instalar.

Outro obstáculo, este mais difícil de vencer, é o uso de versões anteriores do sistema operacional da Apple para fazer a declaração. O site da Receita não informa esse fato, mas o programa para Mac não é compatível com versões como a 10.4 (Tiger). Fizemos o teste na redação da Macworld Brasil e recebemos a mensagem de incompatibilidade.

A solução seria usar a versão multiplataforma, o que também não deu certo. O motivo é que ela pede  a máquina virtual java (JVM) versão 1.6.0 ou superior. No entanto, o Mac OS 10.4 só suporta até a versão do Java 1.5. Ou seja, tudo indica que simplesmente não há como fazer a declaração em um computador com esse sistema (e olha que não é difícil encontrar máquinas com ele). 

irpferro
Programa do IRPF 2010: incompatível com versões antigas do Mac OS X

Quem procura mais informações na documentação que acompanha a versão multiplataforma ainda tem que lidar com dados confusos, como o trecho que diz “Para executar o IRPF 2009 em sistemas Linux ou Macintosh, execute o arquivo exec.sh”, quando o correto seria 2010.

O site e as informações do programa deveriam deixar claro para quais versões do sistema operacional o software é indicado, para que as pessoas não percam tempo instalando programas incompatíveis. Consultada pela redação da Macworld Brasil, a Receita Federal se comprometeu a levantar mais informações sobre o caso.

Em tempo: instalamos o software em um equipamento com Snow Leopard (Mac OS X 10.6) e o processo foi tranquilo. Só descartamos o Receitanet para Mac.

Tags

Junte-se a nós e receba nossas melhores histórias de tecnologia. Newsletter por e-mail Newsletter por e-mail